Author Topic: XML Parsing Error Not Well Formed  (Read 2002 times)

bbasujon

  • Administrator
  • VIP Member
  • *****
  • Posts: 1827
  • I want to show my performance at any where
    • View Profile
    • Higher Education
XML Parsing Error Not Well Formed
« on: January 29, 2012, 07:23:32 AM »
Error. Few of our readers wanted to have a brief instruction to solve this problem and so Iím down the common mistakes that cause this error. Shown below is an example of the error that the Sitemap plugin returns when opened in the browser.

XML Parsing Error: not well-formed
Location: www.your-site.com/sitemap.xml
Line Number 1, Column 1

Removing unwanted .htaccess codes

Not every webmaster has a look at his .htaccess file regularly. Some people think that .htaccess is static, they donít change unless changed by the user, But they are dead wrong, .htaccess files change sometime due to the influence of some plugin.

Say for example, Web Optimizer is one such plugin, that changes the htaccess file, and rewrites some rules. I used this plugin few months before to improve my site loading speed. I had to later remove the plugin has it caused some load on the server. But as I was un-noticed about the .htaccess file. The codes in the .htacces file were still there even after the plugin was removed.

Here is a snippet of the code that I removed from the .htaccess for the file to get the Sitemap.XML to work properly.



As you can see only the content from # BEGIN WordPress to # END WordPress are the only valid content in the file. Remove the invalid codes as above and the Sitemap will work properly.

Note: Its always better to take a backup of your .htaccess file before tweaking with it.
Disabling the PHP zlib Compression

PHP zlib has more been like a culprit returning errors in most of the Cache and the Sitemap plugins. There are more tutorials on how to disable PHP zlib Compression, so Iím not going to cover on that. Some Drupal and WordPress user face problem with disabling the zlib compression, even after changing zlib.output_compression = 0 and adding disable_functions = ob_gzhandler. Incase you meet with such problem do drop a comment here, we would love to help you.

You might also like:
Acquire the knowledge and share the knowledge so that knowing,learning then sharing - all are the collection